gvSIG CE and SEXTANTE GIS Bug Tracker on MantisBT
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000116gvSIG Community EditionBinaries and launcher scriptspublic2011-07-18 17:342013-11-24 13:26
Reporterbenducke 
Assigned Tobenducke 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product VersionAll released versions 
Target VersiongvSIG CE 1.0.0Fixed in Version 
Summary0000116: PROJ.4 binaries (bundled in "libjni-proj" need updating
DescriptionThey are currently at 4.5.0. This is the last version known to work. Later versions (tested with 4.7.0) do not produce correct results when reprojecting with grid files.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000024)
benducke (developer)
2011-07-19 07:56

These bindings also use some dodgy pointer handling. Compilation of the JNI C code produces many warnings like this one:

  libjni-proj4/src/crsJniProj.c:52: warning: cast to pointer from integer of different size

The reason for this is stuff like this:

  src_pj = (projPJ)src;

The intention here is to have "src" represent an object's address in 32 or 64 bit memory space (hence it's a jlong, so it can represent 64 bit addresses, as well).

However, whereas "projPJ" is of type "void*", "src" is a "jlong". On a 32 bit system, the former is 32 bits long, whereas the latter is 64 (there is actually no guarantee that this will be the case on any given system). This mismatch in size results in the warning messages.

In theory, this should be OK on all supported OS. On 64 bit systems, "void*" _should_ be 64 bit, as well. However, this clearly needs testing! If reprojection crashes on a 64 bit system, this should be the first place to look for the cause of the problem.
(0000132)
josecanalejo (administrator)
2012-05-30 15:49

Some problems related with CrsJniProj.dll have been oft reported in the list, e.g.:
//www.mail-archive.com/gvsig_internacional@listserv.gva.es/msg04009.html">http://www.mail-archive.com/gvsig_internacional@listserv.gva.es/msg04009.html [//www.mail-archive.com/gvsig_internacional@listserv.gva.es/msg04009.html" target="_blank">^]
(0000133)
josecanalejo (administrator)
2012-05-30 15:50

Find here the logfile: http://pastebin.com/bUsFdUs2 [^]
(0000245)
jorgearevalo (developer)
2013-08-16 13:48

I have committed the code, replacing the wrapper's PROJ 4.4.9 based code with a PROJ 4.8.0 based one. I think that it should be tested in a 64 bits systems, taking into account the Ben's comment.
(0000277)
benducke (developer)
2013-11-24 12:42

Bundled PROJ4 is now at 4.8.0.

- Issue History
Date Modified Username Field Change
2011-07-18 17:34 benducke New Issue
2011-07-18 17:34 benducke Status new => assigned
2011-07-18 17:34 benducke Assigned To => benducke
2011-07-19 07:56 benducke Note Added: 0000024
2012-03-19 08:26 administrator Category Binaries and installer => Binaries and launcher scripts
2012-05-30 15:49 josecanalejo Note Added: 0000132
2012-05-30 15:50 josecanalejo Note Added: 0000133
2013-08-16 13:48 jorgearevalo Note Added: 0000245
2013-11-24 12:42 benducke Note Added: 0000277
2013-11-24 12:42 benducke Resolution open => fixed
2013-11-24 13:21 benducke Status assigned => closed
2013-11-24 13:24 benducke Status closed => feedback
2013-11-24 13:24 benducke Resolution fixed => reopened
2013-11-24 13:26 benducke Status feedback => resolved
2013-11-24 13:26 benducke Resolution reopened => fixed


Copyright © 2000 - 2011 MantisBT Group
Hosted by Sourceforge.netPowered by Mantis Bugtracker